Weird audio problem with new 2017 500 Abarth.

  1. Welcome to Fiat 500 Forum : US Fiat 500 Cinquecento Forums – General discussion forum for Fiat 500

    Welcome to Fiat 500 Forum : US Fiat 500 Cinquecento Forums - a website dedicated to all things Fiat 500.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Fiat 500 Forum : US Fiat 500 Cinquecento Forums today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: Weird audio problem with new 2017 500 Abarth.

  1. #1
    Junior Member
    Join Date
    Feb 2017
    Posts
    2
    Thanks
    0
    Thanked 2 Times in 1 Post
    Just got my new 500 Abarth auto (non-Beats audio) 4 days ago and I love it, but I found a problem. When the car is on (engine running or engine not running with key in acc/on position) and I'm listening to music, the large driver side speaker doesn't work, and there's no bass from the whole left side of the car. But when I turn the key to OFF all speakers work as they should. Anyone know what could be causing this? And yes, I already made sure audio balance is centered.

    So obviously something is killing the signal to the speaker once the key is turned from OFF to ACC/ON. Maybe there's a faulty relay or something? Can anyone link me to the wiring diagram?
    Last edited by bryanhayn; 02-10-2017 at 08:43 PM. Reason: Because

  2. Remove Advertisements
    Fiat 500 Forum
    Advertisements
     

  3. #2
    Senior Member smark's Avatar
    Join Date
    Aug 2011
    Location
    Lenexa Kansas
    Posts
    11,228
    Thanks
    1,855
    Thanked 1,952 Times in 1,587 Posts
    Vehicle is under warranty. I'd run it by the Fiat Studio. Everything in these cars are ran by computers anymore.

  4. #3
    Senior Member 2.5-12's Avatar
    Join Date
    Mar 2012
    Location
    Twin Cities, MN
    Posts
    181
    Drives
    sport/2013/grigio
    Thanks
    5
    Thanked 48 Times in 27 Posts
    sounds like it may be a fault with your head unit or amp.. CANbus or power trigger coming through the wrong part of the circuit. hard to say, but I concur, take it to the studio for diag.
    2013 Fiat 500 sport. 5MT. Grigio - Euro+Drive flash tune, MPX abarth BBTB, MPX underdrive, RRM corsa cat-back, Madness long draft CAI, Abarth forged wheels, H&R springs, Mopar hitch, Abarth steering wheel, Gucci dash, 4300K HIDs.
    1991 BMW M3 - S54 /5 speed
    1997 Ferrari F355 Spider 6 speed
    1992 BMW 850i 6 speed
    2007 BMW 328iT 6 speed
    2000 Porsche Boxster S 6 speed

    PARTING OUT 2012 ABARTH IN CLASSIFIEDS!!

  5. The Following User Says Thank You to 2.5-12 For This Useful Post:

    Tedolph (02-09-2017)

  6. Remove Advertisements
    Fiat 500 Forum
    Advertisements
     

  7. #4
    Junior Member
    Join Date
    Feb 2017
    Posts
    2
    Thanks
    0
    Thanked 2 Times in 1 Post
    Took it back to the dealer and they said I need a whole new radio unit, which will take 1-2 weeks to arrive. I'll update again after they install it.

  8. The Following 2 Users Say Thank You to bryanhayn For This Useful Post:

    smark (02-17-2017),Tedolph (02-17-2017)

  9. Remove Advertisements
    Fiat 500 Forum
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. 2017 Euro 500 Abarth, here it is!
    By Azzurro in forum Fiat 500 Abarth
    Replies: 14
    Last Post: 05-14-2016, 10:43 PM
  2. Replies: 2
    Last Post: 02-29-2016, 09:51 PM
  3. 2013 Beats Premium Audio Package problem?
    By Mrtmag in forum Fiat 500 Sound Systems and Electronics
    Replies: 4
    Last Post: 05-23-2015, 11:17 AM
  4. Weird overheat problem
    By bigdps in forum Fiat 500 Engine and Technical Discussion
    Replies: 19
    Last Post: 01-31-2013, 01:22 PM
  5. Lets try this again. Weird problem happened twice!!
    By Fiat49 in forum Fiat 500 Engine and Technical Discussion
    Replies: 11
    Last Post: 07-21-2012, 10:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2