Fiat 500 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Hi all,

I've owned my 2012 500 Sport (NA model) for a year this month. Love the car, though i've had a few issues with it. No big deal.

One that I can't wrap my head around, is that my aftermarket stereo doesn't retain accessory power when I shut it off. I honestly didn't ever pay attention with the factory Blue&me stereo before it, because I swapped it out within a week of getting the car.

With that said, map lights activate, still have power to the windows (but not the sunroof in case I forgot to close it). Could this be fuse-related or something different? And in case you're wondering, I connected the radio harness to the yellow wire as the instructions indicated.

A separate issue that I noticed, is that the factory clock doesn't seem to keep up time-wise with my cell phone. I'll set the time and gradually over the next 2 weeks, I'll notice that the clock in my IP is slower than my cell phone. Do these cars have an issue with the clock not being Quartz-standard or something?

Maybe these two issues are related? Maybe not, but I'm not sure. Is there a fuse I should be looking into since RAP seems to work for some things but not others?

Thanks in advance for any help or guidance you can provide.
 

·
Registered
Joined
·
1,040 Posts
There was a service bulletin for a fast or slow clock. Software update at the dealer.
 
  • Like
Reactions: smark

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
Thank you so much, I didn't know that.
I'll contact them about it.

Thank you
 

·
Registered
Joined
·
13,985 Posts
After 11 years of ownership, on my 500 Sport. My clock has never kept the right time. At least now, I don’t have to deal with daylight saving time anymore. I don’t think, there was a software fix, on the clock.

Your sunroof you can check the fuse. Maybe the roofs motor is dead. If you look into the
glove box. There should be a hex key tool. To open your sunroof manually. Remove the small
plug, behind the sunroof. Insert the key.

Sorry can’t help you with the aftermarket radio. I have the OEM Bose system.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #6 ·
You sunroof you can check the fuse. Maybe the roofs motor is dead. If you look into the
glove box. There should be a hex key tool. To open your sunroof manually. Remove the small
plug, behind the sunroof. Insert the key.
Hi Smark,

My sunroof works fine, that's not the issue, but it doesn't seem to retain accessory power like the windows do. I'm not sure if that's by design or not.
I was just using that as an example, because the stereo is the same, power to it stops when I turn off the car.

By contrast, the windows, and map lights retain after power is turned off.
 

·
Registered
Joined
·
13,985 Posts
My sunroof doesn’t retain power. My interior lights I can turn on. The factory radio I can use, without the engine running. I don’t know about the power window. I doubt it.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #8 ·
My sunroof doesn’t retain power. My interior lights I can turn on. The factory radio I can use, without the engine running. I don’t know about the power window. I doubt it.
OK thanks for the clarification.
Maybe the sunroof isn't supposed to retain power after off. I think for the RAP function (Retained Accessory Power), I'm going to locate the fuse and check that maybe.
 

·
Registered
Joined
·
13 Posts
After 11 years of ownership, on my 500 Sport. My clock has never kept the right time. At least now, I don’t have to deal with daylight saving time anymore. I don’t think, there was a software fix, on the clock.

Your sunroof you can check the fuse. Maybe the roofs motor is dead. If you look into the
glove box. There should be a hex key tool. To open your sunroof manually. Remove the small
plug, behind the sunroof. Insert the key.

Sorry can’t help you with the aftermarket radio. I have the OEM Bose system.
I've had all dealer updates done and my clock still loses 3 minutes a month.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #14 ·
Hi all,

...my aftermarket stereo doesn't retain accessory power when I shut it off.

I came across an old thread on this site from 2011 with regards to Blue&Me. Is it true you can set the time off delay from the Blue&Me stereo?
I'm wondering it the delay was turned off, so when I upgraded my stereo, it retained that setting?

Anyone care to chime in if they know about this?
 
1 - 14 of 14 Posts
Top