Fiat 500 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Trying to figure out where to start on this one.

Driving today, the battery charge light came on and would turn off intermittently. Then the ETC light came on flashing, followed by the Check Engine a few minutes later. Got to a spot to stop, turned everything off, waited (and Googled), then restarted.

Only the Check Engine light stayed on, but after another minute or two of driving the Battery and ETC lights came back on. After about 5-10 minutes, another indicator came on (I forget which) and I could smell burning. Pulled over and stopped again. I was only a few miles from home, so I restarted and tried to make it to avoid towing fees. Same deal - Check Engine, followed by ETC and Battery. After another 5 or so minutes, got a warning "Tire Pressure Not Available", then almost every indicator came on in quick succession - airbag, ABS, check oil, and so on. At that point, the car felt extremely wobbly and the accelerator still worked but was very unresponsive. Pulled into a parking lot.

I'm getting in touch with a towing company and my mechanic, but I'm just wondering if anyone has any idea where to start with that and which things to check first

Located in SE Pennsylvania
 

·
Registered
Joined
·
910 Posts
Check electrical. Battery, alternator, cable connections especially UNDER the battery tray and starter ground bolts. There was a TSB for starter ground and ground bolts. Check serpentine belt that goes around alternator You don’t state mileage or age of battery.

The car is ”wobbly” or the engine is running rough?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top