Fiat 500 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My Fiat 500c has over the years had trouble starting during the winter after being left alone for some days. (Around 5-7 days)

I bought the car used in 2012, and since winter 2012 the car has had problems when being inactive for around 1 week (sometimes only 4-5 days) in the cold months.

It became a recurring problem the year after, and I then had the battery changed for the first time. Although the battery was loading alright, it still seemed to be the problem.
However, the same thing has now happened since 2012, and every time I have gone to the autoelectricians, mechanic etc, they have all faulted the battery, and changed it, which has the resulted in around 4 battery changes since 2012.
Because EVERYONE seems to think it's the battery.

HOWEVER, after running my own test where I disconnect the battery from the rest of the car (the big click wire which is attached to the car) I have left the car standing for the amount of days it would usually needs restarting, but now when reattaching the wire to the battery again the car starts without failure every time. Therefore it is not the battery, but rather something inside the car which is using the battery while the car is standing still.

Now the car can not stand still for more than 24hours without the battery being drained. So I have to detach the battery every time i leave the car.

I still haven't figured it out yet, and neither has ANY repair shops autoeletricians etc. PLEASE let me know if you have a fix!
 

·
Registered
Joined
·
1,485 Posts
Interesting. Something is draining your battery. This could be a really difficult thing to track down. Do all electrical components work properly?
 

·
Registered
Joined
·
845 Posts
Check and clean the ground wire connections underneath the battery.
 
  • Like
Reactions: Tedolph

·
Registered
Joined
·
1 Posts
My Fiat 500c has over the years had trouble starting during the winter after being left alone for some days. (Around 5-7 days)

I bought the car used in 2012, and since winter 2012 the car has had problems when being inactive for around 1 week (sometimes only 4-5 days) in the cold months.

It became a recurring problem the year after, and I then had the battery changed for the first time. Although the battery was loading alright, it still seemed to be the problem.
However, the same thing has now happened since 2012, and every time I have gone to the autoelectricians, mechanic etc, they have all faulted the battery, and changed it, which has the resulted in around 4 battery changes since 2012. Because EVERYONE seems to think it's the battery.

HOWEVER, after running my own test where I disconnect the battery from the rest of the car (the big click wire which is attached to the car) I have left the car standing for the amount of days it would usually needs restarting, but now when reattaching the wire to the battery again the car starts without failure every time. Therefore it is not the battery, but rather something inside the car which is using the battery while the car is standing still.

Now the car can not stand still for more than 24hours without the battery being drained. So I have to detach the battery every time i leave the car.

I still haven't figured it out yet, and neither has ANY repair shops autoeletricians etc. PLEASE let me know if you have a fix!
Hi there, I know this post is old but, I am having EXACTLY the same problem with my 2013 Fiat and I was wondering if you were able to figure out the issue?
 

·
Registered
Joined
·
4 Posts
Hi there, I know this post is old but, I am having EXACTLY the same problem with my 2013 Fiat and I was wondering if you were able to figure out the issue?
Did you sort your fiat 500 issue out as I'm having the same problem
 
1 - 5 of 5 Posts
Top