Fiat 500 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Everyone

I have an ongoing issue, my garage and myself are all out of ideas on the cause.

Abarth 595 2017 (Series 4) Fault:
The battery light came on and the power steering went very solid when the car is stopped. Over 4mph the steering feels like it 'unlocks' itself. If you restart the car the light will go off and the power steering functions as normal after a couple of minutes the battery light will come back on and the same fault occurs as above. My garage replaced the alternator which worked but after 1 day the exact fault came back, they suspected a faulty alternator (unlikely from new) they replaced the alternator again, this time it lasted almost 3 weeks before the fault came back again. They have assured me that they have done earth wiring tests (can't confirm this is the case). The battery has also been replaced so that can be ruled out.

There are several threads about this, some people replace the alternator/battery and the issue has gone away. (Same in my case but fault keeps coming back)

Any advice would be appreciated, Thanks.
 

·
Registered
Joined
·
14,070 Posts
Welcome to the forum. What engine codes are you pull up, with a code reader? You didn’t mention. That would help in the diagnosis of the issue. If the problem your continuing to have. Why don’t you take the car back to the mechanic. That charged you for the new alternator. Those alternators are not charging your battery. You car went into limp mode, thats why it felt Sluggish.
 
1 - 2 of 2 Posts
Top