Fiat 500 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
A.C. went out first week after having the car. Any one else had this problem? Is this fixed or am I going to have to deal with it again?
 

·
Registered
Joined
·
1,508 Posts
over two years & 40,000 miles, no problems
 
  • Like
Reactions: andyandrews

·
Registered
Joined
·
13,381 Posts
Never been a issue yet. Never heard of anyone else having that problem. Hope you can get it fix. Nice to have 4 year warranty.
 

·
Registered
Joined
·
27 Posts
My air condition doesn't start right away, this last time it took 10 minutes to finally start, when it's 100 degrees outside it seems forever. Took it to the dealership couldn't recreate the problem.
 

·
Registered
Joined
·
1,987 Posts
A.C. went out first week after having the car. Any one else had this problem? Is this fixed or am I going to have to deal with it again?
Hard to tell via the forum.. if you take it into the studio and its fixed, please let me know what failed. Thank you.
 
  • Like
Reactions: smark

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Hard to tell via the forum.. if you take it into the studio and its fixed, please let me know what failed. Thank you.
Sorry, it was the relay that was bad, (it was fixed), I was wondering if others had this problem as well. It seems no one else has had a bad relay; so I should assume we are fixed at this point.
 

·
Registered
Joined
·
1,987 Posts
Sorry, it was the relay that was bad, (it was fixed), I was wondering if others had this problem as well. It seems no one else has had a bad relay; so I should assume we are fixed at this point.
Thanks for getting back to me... that's good news. Let me know if you ever need anything more...
 

·
Registered
Joined
·
103 Posts
You've found someone that has had the same problem--me. Fall of 2012. AC would cool only for a minute, then go warm. Turn AC off and back on and it would cool for another minute or two, then warm again. Studio had it diagnosed and a new relay switch put in within 30 minutes. No problems since then.
 

·
Registered
Joined
·
1 Posts
Hey guys , so my radio is turning on and it won’t let me change Chanel or anything the only thing the works on it is the on/off button and so as my steering wheel buttons nothing work on it. It’s very weird
I have tried to reset the battery over night but still wouldn’t work.
Radio turns on but no button works and the steering buttons

please help
 

·
Registered
Joined
·
1,987 Posts
Hey guys , so my radio is turning on and it won’t let me change Chanel or anything the only thing the works on it is the on/off button and so as my steering wheel buttons nothing work on it. It’s very weird
I have tried to reset the battery over night but still wouldn’t work.
Radio turns on but no button works and the steering buttons

please help
Hi there-- we're sorry to hear about that!. If you'd like us to look into this for you, feel free to send our team a private message with your VIN and additional details. Thanks! ^CM

Courtney
Fiat Cares
 
1 - 12 of 12 Posts
Top