Fiat 500 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hi all,

Long story short, I hooked up a high voltage (440v capable) 112,000 watt amplifier to my Fiat 500e's traction battery. Lots of pics, videos, and info here: Loud Fiat (@loudfiat) • Instagram photos and videos

Due to an issue I am still investigating, the amp blew a 600v diode internally, tripped multiple 100amp breakers, and blew the main Bussman 350 amp 600v fuse in the battery disconnect. I purchased a replacement fuse, hooked in up, cleared all faults, ran an HVIL isolation test, everything tested positive. Question: What is your vehicle and battery isolation impedance on your 500e? I'd like to compare values for reference.

108425



As soon as I put the key in MAR, the main battery contactors close, the PIM increases the 12v bus voltage from 12v to 14.4 for a second, then the battery controller module throws an HVIL isolation fault and everything shuts down. This indicates the 12v DC/DC function on the PIM works but the PIM may have a short or loss of isolation to the housing causing an HVIL integrity failure.

My current working theory is when the diode blew, the voltage stored in the amp's inductors arced and caused a short while the system was pushing close to 40,000 watts to the amp. So not only did this cause the 400v system to short, the collapsing inductor magnetic field caused a surge in voltage above 600v, stressing some of the PIM components and possibly shorting an HVIL component to the housing (causing an HVIL fault when the PIM is active and contactors closed).

108423


108422


108426


108427


Video of amp running as it cut off.

Instead of overloading this thread with much more technical info, I'll wait to see if anyone with knowledge is willing to chat about this. If so, I can provide lots more details.

PS - please keep your personal opinions about competition sound systems as a hobby out of this thread if possible, I am fully aware many of you don't approve - I am here to speak with the curious builders/makers.
 

·
Registered
2013 FIAT 500e
Joined
·
1,548 Posts
HV Batt Isolation Test is unavail on my free AlfaOBD but it still gave me these numbers:

Vehicle Isolation Impedance: 2.75 MOhm
Battery Isolation Impedance: 5.26 MOhm

Vehicle Isolation Impedance (lowest recorded value): 6.50 MOhm
Battery Isolation Impedance (lowest recorded value): 6.50 MOhm

108454
108455
 

·
Registered
2013 FIAT 500e
Joined
·
1,548 Posts
Wait a sec! How can the lowest recorded value be MORE than the current value?

So I ran it again & the "lowest recorded" stayed the same but current numbers changed to:

Vehicle Isolation Impedance: 2.74 MOhm
Battery Isolation Impedance: 6.50 MOhm
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
HV Batt Isolation Test is unavail on my free AlfaOBD but it still gave me these numbers:

Vehicle Isolation Impedance: 2.75 MOhm
Battery Isolation Impedance: 5.26 MOhm

Vehicle Isolation Impedance (lowest recorded value): 6.50 MOhm
Battery Isolation Impedance (lowest recorded value): 6.50 MOhm

View attachment 108454 View attachment 108455
Ty sir. I found the issue but didn't update this post since no one chimed in. Issue was a bent HVIL pin in the fuse assembly.
 
1 - 5 of 5 Posts
Top