Fiat 500 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Whenever I turn my car on, it says updating and then Update ended and remove my usb. I am unable to turn pin my radio until I use the voice recognition and say "Exit".

Is it my Ecodrive that is doing this or the recent software update that I got at the dealership? I had read someone else had this but they didn't say how they fixed or didn't fix,

Maybe its time for a call to Customer Service or the "Stealership"

Brock
 

·
Registered
Joined
·
126 Posts
Mine does it every time I plug in the USB Drive (Eco Drive is on, btw). I remove the USB, plug it back in and it's good. It is annoying that I have to go through that process, though.

Thn again, maybe I'm doing something wrong.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
Fixed it!

Mine does it every time I plug in the USB Drive (Eco Drive is on, btw). I remove the USB, plug it back in and it's good. It is annoying that I have to go through that process, though.

Thn again, maybe I'm doing something wrong.
Unplugging and re-plugging in don't do it....
  1. Unplug USB and update the ecodrive program on your computer ie download the data
  2. Erase all iFIAT info or folders on USB
  3. Re-install ecodrive on your USB by going to ecodrive website and It will ask you to "Prepare your USB"
  4. Put USB back in car...It will no longer say UPDATING...
Problem fixed! I think the problem was caused by me running ecodrive for a day without the USB in place.

Important thing is that it stopped saying UPDATING! over my speakers...and then nothing would work...no phone, no radio...

Brock
 

·
Registered
Joined
·
7 Posts
updating...

had that too -- simple solution -- was to depress small round button on left rear of steering wheel -- msg stopped and radio came back on... no need to do any other stuff (at least for me).
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #6 ·
had that too -- simple solution -- was to depress small round button on left rear of steering wheel -- msg stopped and radio came back on... no need to do any other stuff (at least for me).
Yes, but I had to do that everyday! It was getting annoying.

And as well as the button, I had to say "exit" for the rest of the functions to work again.

The longer process worked all day today so its good!:)
 

·
Registered
Joined
·
249 Posts
I have found a permanent fix that has worked very well for me so far. YMMV.

After installation or update of the EcoDrive by
1. placing USB drive into the slot in the glove box
2. turning ignition into the accessory on position without starting the car
3. after "update ended" is displayed and "remove usb drive" is said, removing the usb drive
4. starting the car,

do not stick the usb back in at this point. Instead, take your usb to your computer and remove the following files from the drive:


  • install.inf (which will be found outside of the iFiat folder)
  • UD4_N_L_4_EcoDrive-USA-7020_single-install_T.ARM926.CAB (which is found inside of the iFiat folder)


You may then replace the USB into the slot in the glove box and it should not "update" again.

Again, YMMV.
 

·
Registered
Joined
·
87 Posts
I have found a permanent fix that has worked very well for me so far. YMMV.

After installation or update of the EcoDrive by
1. placing USB drive into the slot in the glove box
2. turning ignition into the accessory on position without starting the car
3. after "update ended" is displayed and "remove usb drive" is said, removing the usb drive
4. starting the car,

do not stick the usb back in at this point. Instead, take your usb to your computer and remove the following files from the drive:


  • install.inf (which will be found outside of the iFiat folder)
  • UD4_N_L_4_EcoDrive-USA-7020_single-install_T.ARM926.CAB (which is found inside of the iFiat folder)


You may then replace the USB into the slot in the glove box and it should not "update" again.

Again, YMMV.

You are a brilliant man.
 
1 - 9 of 9 Posts
Top