Fiat 500 Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So my girlfriend has a 2016 fiat 500e and she dropped her charger recently and now whenever we plug it in it just gives goalposts or doesn’t charge but when we go to a charger station it charges just fine so I’m sure it’s the charger anyone know what to do or if I can fix the charger?

This is the charger she has
Adapter Adapter Gadget Ac adapter Audio equipment
 

· Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
If it's just the plug she dropped, & it's cracked and you're handy with household wiring, you might be able to cut it off & replace it.

The OEM unit is sealed, so even if you're really handy at fixing electronics you'd have to cut it open first. You might want to do that anyway just out of curiosity, since you can't make it any worse than it already is.
yeah for now we just Ordered a different one and I’m gonna see if that works it charges fine at ChargePoint and stuff but when we plug hers In it doesn’t give it a charge makes the clicking sound but does nothing and the box on the charger isn’t blinking red so I think it’s getting enough juice
 

· Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
Oh, duh! Your pic above is the same as my 2013, so if it shows the 6 LEDs as I described then it seems to be ok.
so we tried to do what you said it didnt work we ended up ordering a new charger and it worked heres what happens when we charge with her old charger
 
1 - 4 of 4 Posts
Top