Fiat 500 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,550 Posts
Discussion Starter #1
One mildly aggressive start, esp on with a little wheel spin, and now my car creaks very loudly and painfully when rolling off the clutch. It's horrible! Something must be broken. Gonna have to call the dealer tomorrow. :(
 

·
Registered
Joined
·
1,550 Posts
Discussion Starter #3
It's gone, now I'm stumped. I went to test it again first thing this morning, and the noise was no more. I want to know what it was.

Best way to describe the noise was when you slowly roll of the brake on an automatic car, and they're still slightly grabbing, producing a groaning noise. It was making that noise on start-up and when engaging first gear. I've replaced worn engine mounts on my other car, and these symptoms were similar.

Scared me.:mad:
I hope it doesn't come back.
 

·
Registered
Joined
·
76 Posts
Overheated clutch (from "hard launch") temporarily making the friction material grabby ... issue went away after everything cooled down ... perhaps ????
 

·
Registered
Joined
·
1,550 Posts
Discussion Starter #6
Overheated clutch (from "hard launch") temporarily making the friction material grabby ... issue went away after everything cooled down ... perhaps ????
Quite possible. But I'll tell ya, it definitely sounded like something was BROKEN. Horrible feeling.
 

·
Registered
Joined
·
393 Posts
Overheated clutch (from "hard launch") temporarily making the friction material grabby ... issue went away after everything cooled down ... perhaps ????
Seems as if thats the problem, after reading what the OP posted all i can think of the problem being is the clutch.

Quite possible. But I'll tell ya, it definitely sounded like something was BROKEN. Horrible feeling.
Sure does sound like something broke, any update on the situation?
 
1 - 7 of 7 Posts
Top