Fiat 500 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm 1 month into a lease on a 2019, and I have never been able to use the UConnect app. I have a Mopar account, but when I use that info to log into the app, it tells me "no active subscription". I called customer service, and after a 20-minute hold, the befuddled rep told me she'd called both UConnect and Sirius Guardian, and nobody knew what to do. She suggested I ask my dealer. I spoke to the service department today, and they said they were unfamiliar with this issue, but that they'd look into it when I take the car in a couple weeks because a side panel has come unglued.

From reading older posts on this site, it sounds like the app is pretty unreliable, but I should at least be able to log in, right? Anybody got any insights?
 

·
Registered
Joined
·
134 Posts
You'll likely not get too much experience here with the app, as most people here have their cars after a 3 year lease, and subsequently after mopar has removed any feasibility of the UCONNECT app.

that said, I'd suggest calling the Fiat Customer Care directly, and getting assistance from them.
 

·
Registered
Joined
·
12 Posts
I too had this problem with my 2018. Support was absolutely useless and I got bounced between UConnect, FIAT, Mopar, even Sirius since no one really understands the car. I think I signed up here Mopar Owner Connect Account

That said the UConnect app is kinda useless. I frequent updates, commands rarely make it through, limited data available, etc. Faster to just run out to the garage for me.
 

·
Registered
Joined
·
8 Posts
myfiat500e.com to the rescue. Users report good things. It's cheaper than a remote start system installed on any other vehicle and gives you far more function.
 
1 - 6 of 6 Posts
Top