Fiat 500 Forum banner
1 - 20 of 92 Posts

·
Registered
Joined
·
700 Posts
Discussion Starter · #1 ·
Recently installed the sprint booster and enjoyed my 80 mile trip home i like the differnece in my pop off the line hold on spin the tires


so i got home and installed my corsa intake in red....install is very tight...took it for a test drive and like wo....it has a lot of lag
not allot of difference if not any compared to stock i would say stock is better...only thing i did not do is disconnect the battery upon install if thats the reason i will disconnect and reconnect

but just makes allot of noise at the high end...does nothing at the start so far im not satisfied

any suggestions

thanks

jim
 

·
Registered
Joined
·
4,580 Posts
Disconnect the battery for 15 min, press on the brake pedal about 10 times. Should not lag unless you didn't tighten everything. I know I had to reset my Ecu after the exhaust change because it was losing fuel efficiency and response.
 

·
Registered
Joined
·
4,580 Posts
stupid question disconnect for 15 minutes reconnect then brake pedal 10 times then start up
Disconnect then go press the brake to get any remaining power out of the system, then sit for 15 min, reconnect, start.
 

·
Registered
Joined
·
700 Posts
Discussion Starter · #5 ·
see i had to ask thanks will let you know how it works after the disconnect the instructions should have a better explanation for this as well as better diagrams... mine was a copy of a copy........thanks lorvar
 

·
Registered
Joined
·
4,580 Posts
see i had to ask thanks will let you know how it works after the disconnect the instructions should have a better explanation for this as well as better diagrams... mine was a copy of a copy........thanks lorvar
No problem, make sure everything is tightened up
 

·
Registered
Joined
·
700 Posts
Discussion Starter · #7 ·
so i got another question ...where is the other battery.. i was told we have a second battery for the accessories...
was this a line or is it true......10 minutes to go
 

·
Registered
Joined
·
4,580 Posts
Not that I know of, just make sure the entire wire was removed from the battery terminal.
 

·
Registered
Joined
·
700 Posts
Discussion Starter · #10 ·
yes i took everything off from the hub...the bracket with the two wires attached shouldnt the neg terminal have a cover on it like the positive side...there are two holes for them....seems wierd with one side covered with a red cap and the other is naked
 

·
Registered
Joined
·
700 Posts
Discussion Starter · #12 ·
im back it runs better...but im not sold on the thing it gets loud now under acceleration but i dont see a differnece
from the stock with the sprint booster to the sprint with the corsa my mileage is dropping thats about all i see other thatn the loud noise from the hood when i step on it

and the theory of the second battery... when i got back in had to change the time and date...but all my presets are still there on the radio.....
 

·
Registered
Joined
·
700 Posts
Discussion Starter · #14 ·
yes i know about this perk...but growl and no umph....

they say this has the best umph for your money regarding intakes it isnt doing anything for me to justfy the cost

the sprint booster filled in the lag gap nicely.... i just was hoping for a more positive response i have this one hill that the car barely hangs on in 5th gear at 75 and i dont have to downshift...with the corsa i get the roar and i had to downshift to 4th so it fails in this area for me again roar and no umph yes i know its not a tumor...lol
 

·
Registered
Joined
·
4,580 Posts
The one I'm working on has pull from the get go and will get loud after 3500 rpm. After the free flow exhaust, the pull has dropped a bit from the start but spread more evenly across the rpm range.
 

·
Registered
Joined
·
3,936 Posts
The one I'm working on has pull from the get go and will get loud after 3500 rpm. After the free flow exhaust, the pull has dropped a bit from the start but spread more evenly across the rpm range.
Too much flow. Not enough back pressure causing loss of Torque. I put an large exhaust on an SER and gained more hp up top but the loss of Torque killed me of the line.


Fiat 500 Argento Sport
 

·
Registered
Joined
·
765 Posts
Too much flow. Not enough back pressure causing loss of Torque. I put an large exhaust on an SER and gained more hp up top but the loss of Torque killed me of the line.


Fiat 500 Argento Sport
Thats one of the reasons I left my resonator in place. My car leaps off the line. Can't say if theres a ton more HP or Torque, can only say it pulls harder, and is definitely a little quicker. The question of cost effectiveness is an important one, and since we aren't making race cars here, I feel keeping things as low cost as can be done reasonably is vital. Its as much of a hobby for me as anything else. I invested more in my seat covers ($269) than I have in my Intake and Exhaust combined ($265)
 

·
Registered
Joined
·
4,580 Posts
Too much flow. Not enough back pressure causing loss of Torque. I put an large exhaust on an SER and gained more hp up top but the loss of Torque killed me of the line.


Fiat 500 Argento Sport
That's why I'm doing a redesign on the intake. The torque is way better than OEM, but it was a trade off for the beautiful gurgle and popping of the exhaust.
 
1 - 20 of 92 Posts
Top