Fiat 500 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3,936 Posts
Discussion Starter · #1 ·
Recently I
noticed that my radio controls go wacky and then back to normal.

For example last nite the left control starting adjusting volume????? up and down few mins later it was back to changing channels.

also instead of changing sat channel one at a time it occasional will skip to a new section this is using up down keys NOT the center key. Most times it's fine.

Any likely causes. ECU? Switches work fine so not bad switch just varied functions of sorts!

Anyone else??


Sent from my Argento 500
 

·
Super Moderator
Joined
·
22,120 Posts
just started happening recently and very intermittent. Which is the worst kinda problem Sent from my Argento 500
Def agree with ya there, had some electrical problems myself not long ago, ended up with another car (500) somewhat due to that as well as the storm related damages)
 

·
Registered
Joined
·
1,999 Posts
just started happening recently and very intermittent. Which is the worst kinda problem


Sent from my Argento 500
Fiat49:

You know what Im going to recommend you do.. :).. if your steering wheel controls are phantomly adjusting your stations, have the studio check it out... there may be debris or moisture in the buttons.. let me know what they find.
 

·
Registered
Joined
·
3,936 Posts
Discussion Starter · #8 ·
Fiat49:

You know what Im going to recommend you do.. :).. if your steering wheel controls are phantomly adjusting your stations, have the studio check it out... there may be debris or moisture in the buttons.. let me know what they find.
you missed the main point. controls got temporarily reversed. volume moved on left side! worked fine but not proper function


Sent from my Argento 500
 

·
Registered
Joined
·
1,999 Posts
you missed the main point. controls got temporarily reversed. volume moved on left side! worked fine but not proper function


Sent from my Argento 500
Fiat49: Oh ok.. wow that is strange.. I have never heard of that before..
 

·
Registered
Joined
·
313 Posts
I have the same issue every now and then, also if my lights are off, and I flash my high beams, it switches the media from cd to usb....
 

·
Registered
Joined
·
1,999 Posts
I have the same issue every now and then, also if my lights are off, and I flash my high beams, it switches the media from cd to usb....

I would definitely have a studio check that one out, that is very strange.
 

·
Registered
Joined
·
1,999 Posts
I have the same issue every now and then, also if my lights are off, and I flash my high beams, it switches the media from cd to usb....

dumped500: Not sure if there is a problem with the multi-function switch or with the steering controls... that is so odd, I have never seen this before. Better have a studio check it out.
 
1 - 13 of 13 Posts
Top