Fiat 500 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Good afternoon all,
I recently had my Fiat 500 Diesel Special edition Petrol 2009 services and during the service I had the front discs and pads replaced. Drove it for a couple of weeks and all was fine. I went to use it yesterday after not having driven it for a week. It wouldn't start, it was like the battery was totally dead and the dashboard just displayed the error EBD Failure. I ordered a new battery as I do not know when the battery was last replaced as I bought it about two years ago. Hopefully that will resolve the issue but if any of you have any ideas that would be great.
Thanks
 

·
Registered
Joined
·
1,928 Posts
Good afternoon all,
I recently had my Fiat 500 Diesel Special edition Petrol 2009 services and during the service I had the front discs and pads replaced. Drove it for a couple of weeks and all was fine. I went to use it yesterday after not having driven it for a week. It wouldn't start, it was like the battery was totally dead and the dashboard just displayed the error EBD Failure. I ordered a new battery as I do not know when the battery was last replaced as I bought it about two years ago. Hopefully that will resolve the issue but if any of you have any ideas that would be great.
Thanks
Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
FiatCares
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
FiatCares
I'm based in the UK. Do you work for Fiat?
 
1 - 4 of 4 Posts
Top