Fiat 500 Forum banner

21 - 30 of 30 Posts

·
Registered
2013 FIAT 500e
Joined
·
2,187 Posts
Brakes:


As for the rest, I wonder about the cost & hassle of getting it to the dealer & back, compared to that of the WiTech software and interface. Or maybe you could track down someone already using that (for any of the great many other FCA vehicles) who could make it work on yours.
 

·
Registered
Joined
·
2 Posts
GUESS WHAT!? FIXED ! without going to stealership! - so as you saw above I was having the same crazy ABS, ESC, RBS etc etc lights and errors coming on - and I got the Konnwei and alfaOBD and was able to clear them over and over, but they'd always come back. Well, I decided to order the various adapters for it too (Amazon - cheap) like the Yellow one it calls for to look at the main computer etc, and while waiting for it to arrive I left the Konnwei plugged into the car, and the (12v) battery was dead the day I tried to start it! So, I charged it up and it then came up with a Check Elec Syst error now! I ran the tests and saw a lo batt 10v error in the log that set it off. I check the battery and Lo' and Behold! One of the cells was low on water and the plates were showing! I filled it, and all of them, and charged it up overnight, and - cross my fingers - it's fine now. All errors cleared - been driving it for 3 days, and no problems. It has been kinda hot here in AZ - with 100+ every day, and I have been remiss in checking my 12v batt waters. So there you go, but answer me this Batman - why the heck didn't Fiat put in a 12v low batt sensor and signal on the dash light in the dang thing!? I mean really! The only way to know if your 12v batt is going is that you get all sorts of crazy errors? Seems like a major design oversight by the software engr.
 

·
Registered
2013 FIAT 500e
Joined
·
2,187 Posts
Thank you very much for the update! I'm sure I'm one among many who really appreciate such follow-up reports, especially when they include such an easy solution.

There IS supposed to be a low 12V warning, which reportedly shows a day (or half) before failure to start, but at least 2 other users have reported 12V failure without warning.

500e 12V can fail in as few as 23 months, so after that it's advisable to have a backup plan like a small portable jumpstarter.
 

·
Registered
2013 FIAT 500e
Joined
·
2,187 Posts
With error codes after 12V replacement or disconnect, cycling the key off 5 times to a fully black screen (not just dark grey) can sometimes clear the codes, so that would be something to try before bothering to go for service.
 

·
Registered
Joined
·
3 Posts
I brought it in to fiat service, after their diagnostic review they said bad hub and speed sensor. Again it is under extended warranty and will hopefully be good tomorrow.
We will see if they are correct.
 
21 - 30 of 30 Posts
Top