Fiat 500 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2,057 Posts
Discussion Starter #1
So before i begin explaining my issue i just want to say that YES i am taking it to the studio as soon as i get a day off work.

now here is the deal, twice now i have dissabled the ESC to off-off and when im done doing whatever i do with ESC off i press the button to reactivate the ESC and nothing. the light is still on indicating ESC is off no matter how hard, long, and how many times i press. i dont see this as a problem that will ruin my car, but it is an obvious safety issue.

has anyone heard of this going on or know what it could be? thanks for any help and ill keep ou posted on what the studio can do for me.
 

·
Registered
Joined
·
2,057 Posts
Discussion Starter #3
i will come back after a few minutes, not long enough to turn the car off and then back on. and i just do that to merge into traffic in the mornings. the traction control has been more annoying than usual lately.
 

·
Registered
Joined
·
378 Posts
What is it that is annoying you about it? Most of the systems cut power and apply brakes to work. I have found the best approach is to just let up on the gas when I see the light flashing...
 

·
Registered
Joined
·
794 Posts
Oliver500,

I won't nag you about the studio, promise. I've found that pressing the button to turn ESC off (and the light on) doesn't always work. I can press it 8 times with no effect. Then, it starts to work. I only realized this as I was trying to push the fog light button. My assumption is that the switch is faulty. I must read the manual again, and then pay attention to the off-off/ two-push action.
 

·
Registered
Joined
·
2,057 Posts
Discussion Starter #9
bainbridgeny- the Pop has the single push for "kinda-off" and the hold down for "mostly-off"

Umbrianissmo- i dont have the fog light switch and was about to pull the dash off to check the switch.

i tried today to replicate the problem before i take it to th studio tomorrow, but its been working fine. it may wind up being just nothing, but i dont feel like taking the 25 mile drive to not be able to replicate it.
 

·
Registered
Joined
·
903 Posts
I thought I read somewhere this was to be switched when the vehicle was either parked or at a low speed. Does it make a difference when you switch it?
 

·
Registered
Joined
·
1,897 Posts
So before i begin explaining my issue i just want to say that YES i am taking it to the studio as soon as i get a day off work.

now here is the deal, twice now i have dissabled the ESC to off-off and when im done doing whatever i do with ESC off i press the button to reactivate the ESC and nothing. the light is still on indicating ESC is off no matter how hard, long, and how many times i press. i dont see this as a problem that will ruin my car, but it is an obvious safety issue.

has anyone heard of this going on or know what it could be? thanks for any help and ill keep ou posted on what the studio can do for me.
Yea that is odd. You should be able to activate it while driving, rather than having it automatically reset when the vehicle has an ignition cycle, ON/OFF
 

·
Registered
Joined
·
115 Posts
I see that this thread hasn’t been updated in a month or so..
Were you able to find a solution? I have a similar but opposite problem. I cant turn mine off sometimes. It doesnt matter if i am moving or stopped at the time, if it is in gear or not, parking brake on/off.. i cant figure out any pattern with how it works/doesnt work.
I have tried re-starting the car, pushing the button several times, single press, long press, jovial press, really forceful angry press, SNEAKY press... nothing works. Then, all of a sudden it works fine and will go on/off easily as many times as i want.

This is a really irritating issue because i have a steep drive way and when there is snow on the ground i am unable to get to the top with it on. It just goes *CRUNCH CRUNCH CRUNCH* and sits there spinning the tires. It has taken me more than 5 minutes and several tries to make it up in the winter.

Sometimes the cruise control button doesn’t work right away either. That one usually works after 2-3 tries though.
 

·
Registered
Joined
·
5 Posts
So before i begin explaining my issue i just want to say that YES i am taking it to the studio as soon as i get a day off work.

now here is the deal, twice now i have dissabled the ESC to off-off and when im done doing whatever i do with ESC off i press the button to reactivate the ESC and nothing. the light is still on indicating ESC is off no matter how hard, long, and how many times i press. i dont see this as a problem that will ruin my car, but it is an obvious safety issue.

has anyone heard of this going on or know what it could be? thanks for any help and ill keep ou posted on what the studio can do for me.
 

·
Registered
Joined
·
5 Posts
I’ve been dealing with the same issue. It’s indicating you hill assist is unavailable. I turn the ESC OFF button on. Sometimes it’s gone after the car get a chance to sit (or reset) and sometimes it doesn’t. I have had issues with “dummy lights” and electrical flukes like that.
 

·
Registered
Joined
·
1,897 Posts
I’ve been dealing with the same issue. It’s indicating you hill assist is unavailable. I turn the ESC OFF button on. Sometimes it’s gone after the car get a chance to sit (or reset) and sometimes it doesn’t. I have had issues with “dummy lights” and electrical flukes like that.
Hi joesgirl13,

I certainly understand why this would be concerning. If you end up addressing this with your dealer, please let us know via PM. We would be more than happy to provide you with an additional layer of assistance for that process.

Mark
FiatCares
 
1 - 17 of 17 Posts
Top