Fiat 500 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My wife and I just bought two 2012 Sports last evening. We got up this morning to go have coffee at the in-law's; no worries. We had to go back to the dealership to drop off our trade-in and on th way, the wife called and said her EVIC was totally blacked-out. We stopped at a local Sheetz and I went over to have a look and sure enough, totally blank. We went in to get a drink and came back out and she started it up, same thing, nothing. We arrived the dealership and told our salesperson of her issue and they took a look. Well, wouldn't you know it, it was working. They took both cars in for detailing and when they came back, it was blank again. They gave her a loaner and will work on it Monday. Anyone else had this problem?
 

·
Registered
Joined
·
182 Posts
Is this a 500c by any chance? Ours went black the first week we bought the car after the Cabriolet top mechanism cut a wire to the 3rd brake light, which is on the same circuit apparently. Quick fix. No problem since. good luck.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
It is not, it's a Sport but that is a good point. I will have to tell the service department. They will appreciate the input I am sure. They don't usually want to spend as much time doing the diagnostics when it is on their dime. ;)
 

·
Registered
Joined
·
9 Posts
Here's another member from NC! Weown2 sorry to hear about the issue and I hope the get it resolved quickly for you. My wife and I were in Hendrick yesterday morning buying our 2nd Fiat. About 3 weeks ago we bought a Verde Olivia Pop for my wife and I ended up liking it so much we decided to go back and purchase a Verde Chiaro for her! She loves the color and it worked out perfect for us. The funny thing is that they mentioned a husband and wife the day before buying two, so we didn't feel like the only crazy ones! Good luck and congrats on the new Fiat's.
 

·
Registered
Joined
·
225 Posts
I hope Hendrick has the mess together now, last August they SUCKED, nice to see some locals if you will sporting Fiat now, I felt pretty alone for some time...hehe.
You want to feel alone Tweak? Try living in the mountains near Asheville. The only 500 I have seen in a year was one Rosso on I-26 passing through.


On the positive side, I'll have the only Abarth dodging about 10,000 pickups. :) The roads are great though.

Cheers from the other side of the state.

Cheers
 

·
Super Moderator
Joined
·
22,120 Posts
You want to feel alone Tweak? Try living in the mountains near Asheville. The only 500 I have seen in a year was one Rosso on I-26 passing through. On the positive side, I'll have the only Abarth dodging about 10,000 pickups. :) The roads are great though. Cheers from the other side of the state. Cheers
At first alone was cool but then I kinda wanted to find other near me to hang with if possible ya know, hopefully one of these days I will get up your way and enjoy some of the places I only vaguely recall from when I would visit the NC mountains so many years ago as a child. :cool:
 

·
Super Moderator
Joined
·
22,120 Posts
This happened to us last night right as we were putting the top up- I knew they had to be related somehow but was glad to see this and guess what? No 3rd brake light---very helpful, thank you! :)
Welcome to the forums, hope the studio resolves your problem quickly now that you have the reason why it is a problem! Also, hope you stick around and enjoy the forum. :)
 

·
Registered
Joined
·
2,001 Posts
My wife and I just bought two 2012 Sports last evening. We got up this morning to go have coffee at the in-law's; no worries. We had to go back to the dealership to drop off our trade-in and on th way, the wife called and said her EVIC was totally blacked-out. We stopped at a local Sheetz and I went over to have a look and sure enough, totally blank. We went in to get a drink and came back out and she started it up, same thing, nothing. We arrived the dealership and told our salesperson of her issue and they took a look. Well, wouldn't you know it, it was working. They took both cars in for detailing and when they came back, it was blank again. They gave her a loaner and will work on it Monday. Anyone else had this problem?
Weown2: Ugh! I apologize.. and so soon after the purchases... with an intermittent problem like that, the dealer must experience it... I would have the studio check it out...if it happens more frequently, send me a PM with your VIN and I would be happy to remain involved until resolved.. also I will provide a rental if needed.
 
1 - 14 of 14 Posts
Top