Fiat 500 Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi I have a fiat 500L 2014

When i start my car sometimes, when i put it in drive or reverse and i start pressing the gaz peddle i get an error message... It says check transmission and to put the car in neutral, reverse then in park. Sometimes after doing it it starts working normaly but usualy i need to put it in park and wait 2 to 5 minute (usually i close most everything down but keep the car running) ... sometimes it will work somewhat and gives me another transmission error... it then says to service transmission and the transmission works inapropriatly and the service engne logo appears (switched from 3 rd gear to 6th)... other time it will work correctly till i stop and then i have to put my 4 way flasher put it in park and wait another 2 to 5 min ... other times it will work properly after ...

there's no transmission error code left behing even if the car says it's a transmission issue, All the error code point to low charge in the batterie but when ever they test it the batterie is fine and doesnt need much charging (it was also charged not even 6 months ago) the intirer electric system to charge the batterie was checked many times


does anyone know what that message code mean or did you get your car fixed and know whats the issue cause all the mechanic have absolutely no idea what i mean when i tell them about this issue

i've also had many issues concerning the batterie this winter could it just be that the batterie is a lemon... or are they missing something... they said my old batterie was perfectly fine too
 
1 - 2 of 2 Posts
Top