Fiat 500 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've seen some of the posts on this website trying to get a clue as to how to fix this isssue. Alright so about 5 months back my car wouldn't start. I think it would try to turn over but it was just a click. We replaced the battery and looked all over it and it didn't work. So we took it in and they said it was the starter. So now we have a new starter. About a month ago the car started having problems again. This time the car would turn on but wouldn't turn over. Not even a click. Just silent. We looked at it and couldn't find what was wrong. Tried jumping it and it wouldn't work. Next day we tried to start it again and it would start. Couple days later it wouldn't start. Next day it would start. So we had it towed to Midas because we figured it was an electrical issue. They ran a full diagnostic and couldn't figure out what was wrong with it because apparently it started every single time for them. So we took it home. It wouldn't start again. We took it to someone who specializes in foreign cars. He said that one of the bolts connecting to the starter was loose and he tightened it and it started every time. Few days later it's not starting. We have no idea what's wrong and I'm tired of paying people to do nothing. I have to work and now I have to burden other people because my car isn't working. Please and info is useful.
 

·
Registered
Joined
·
902 Posts
Hi and welcome aboard @SierraP. the problem could be in the starter terminal ring to which the battery cable hooks to. (If I am explaining that correctly)
please read the following link, or have your mechanic read it. This terminal contact ring has been known to break apart, and thus break the circuit Intermittently. #2 is where the terminal ring is located, which attaches to #3. Hope this helps and I wish I'd seen your post sooner.

 
1 - 2 of 2 Posts
Top