Fiat 500 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi, just rolled up to red light in drive. It turned green. Car wont move. Revs are going up, as if engine is disconnected from wheels.
Drive light on dashboard was on. I tried switching to P twice (it made strange nosie as in manuals when you wont put the gear properly). Went back to drive, no change. Shut down engine, turned back on, nothing.
Cop came, asked to switch to neutral. I did, he pushed the car, then I switched to D and it worked again.
Wth?

This is not the shifter cable issue. I had that one twice before.car is at 141k miles.

This is extremely dangerous, i had warning lights on, people would still honk and drive at me with 60mph having to go on the side to pass me.
 

·
Registered
2013 fiat 500 pop
Joined
·
58 Posts
hello IronKitt, I belief you can run a scan tool n retrieve a transmission code, check the trans fluid, also smell the trans oil for evidence of burnt clutch disks, good luck
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Took it to Fiat Dealer Service. They were able to reproduce the issue. They didn't see anything wrong with cabling etc. They did ~400$ transmission fluid replacement. Half of fluid was missing and it was dark. They say it must be the transmission and replacement will be like 4500$+ (cost + labor).
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Ended up in Transmission rebuild. Fiat Dealer Service asked for $6000.
Independent transmission repair shop asked for $1500, ended up being $3125.
Transmission rebuild 1705$ (with computer) + New Axle (225) + Labor (795) + Main seal (196.04 to engine)

108467


108468


108469


108470
 
1 - 4 of 4 Posts
Top