Fiat 500 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone,

I'm new here :) I have had my 5-speed Sport for about 2 months (finally got my plates today, YAY!). When I drove off the lot, the first thing that happened was my check engine light went on. I immediately called the dealer and they said that it was probably because I didn't cap the gas tank tightly enough when I put in gas (they gave me a car with an empty tank :mad:). After the light wouldn't go off for a couple of days (I retightened the gas cap) I brought it in and they said the computer needed an update, so they did that. After a couple of days, the tire pressure sensor light came on. There was nothing wrong with my tire pressure. Then, when I filled the gas tank again, the tire pressure light went off. But, the check engine light came back on. The dealer says that the computer needs another update. The dealer is really far for me so it is no easy or quick task to get there so I haven't bothered with it yet (it's been over a month with my check engine light on non-stop).

Is anyone else having issues like this?

Pam, white 2012 5-sp sport
 

·
Registered
Joined
·
614 Posts
Since you've had three separate instances, I'd would push the dealer for a computer replacement and if they balk call Fiat.

Sometimes you have to make a lot of noise to get a dealer to give you their undivided attention.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Will probably let them try to fix it one more time...

Thank you for your reply. I will probably make time to get my car out there to try their new computer update and if that doesn't work, insist on a new computer. I did mention it last time and they, of course, said No. But, I will make an issue of it if this update doesn't fix the problem.

I noticed someone else has a leaky rear windshield spigot. Me too.

Pam
 

·
Registered
Joined
·
343 Posts
This is my second time, too. Yesterday, the temp light came on, then a warning message flashed on the display (too quickly, couldn't read it), then everything reset itself and was fine... weird.
 

·
Registered
Joined
·
606 Posts
Hi

That sounds wierd, and I understand your concerns. I guess I'd suggest doing as Deron noted.

On a side note though, I did have the low tire pressure light come on once, but while looking at the tire in question I didn't notice anything wrong with it. To be safe I double check with a tire guage and found that it was in fact a few pounds low. So I'd make sure to double check everything the computer warns you about until you finally get the overall issue resolved, just to be safe.

Regards

Pat
 

·
Registered
Joined
·
606 Posts
Hi

The amber Tire icon (with an exclamation point inside it) lit up and then across the EVIC display a statement scrolled across stating which tire was low. I think the TPMS logo is on the upper right hand side of the speedometer/tachomater cluster.

Regards

Pat
 

·
Super Moderator
Joined
·
22,120 Posts
The amber Tire icon (with an exclamation point inside it) lit up and then across the EVIC display a statement scrolled across stating which tire was low. I think the TPMS logo is on the upper right hand side of the speedometer/tachomater cluster.

Regards

Pat
Thank you very much Pat. :cool:
 

·
Registered
Joined
·
1,262 Posts
There has been a recall to the ecu regarding the engine light coming on. I had my car in the dealership last week to get my side skirt replaced and they did the recall too
 

·
Registered
Joined
·
75 Posts
Hello - new here... So I take it, the conclusion of this thread is that the ECU (whatever that is) is going to be recalled/replaced - across the board for all Fiat 500's? Yes, or no? Having an engine light or tire pressure warning light on, on the dash is very distracting whilst driving. Hope they get it fixed for you. The squeaky wheel gets the grease, always remember that.
 
1 - 10 of 10 Posts
Top