Fiat 500 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
Hi everybody!

Anyone have any experience with their headlights flashing on and off while driving? I've checked the two grounds that come off the negative terminal of battery and replaced the original battery hoping that would solve it but it didn't.

It seems to happen what I hit bumps in the road, the headlights, headlights alone, turn off and then back on again immediately. Not the fog lights, not the turn signals, not the DRLs, just the headlights. Not even the indicator in the dash that tells you the headlights are on turns off.

Appreciate any help!
 

·
Registered
Joined
·
936 Posts
If it's both of them, I'd suspect the BCM is bad. You have a couple of options if that's the case. Pay Fiat a lot of money for a new BCM, or try to repair it yourself. What happens is the solder on the relays cracks and causes issues. The solder may need to be reflowed.
 

·
Registered
Joined
·
130 Posts
Discussion Starter #3
It does indeed happen to both. I do hear a relay clicking underneath the dash when it does happen.
 

·
Registered
Joined
·
1,848 Posts
Hi everybody!

Anyone have any experience with their headlights flashing on and off while driving? I've checked the two grounds that come off the negative terminal of battery and replaced the original battery hoping that would solve it but it didn't.

It seems to happen what I hit bumps in the road, the headlights, headlights alone, turn off and then back on again immediately. Not the fog lights, not the turn signals, not the DRLs, just the headlights. Not even the indicator in the dash that tells you the headlights are on turns off.

Appreciate any help!
Hello Manco,
We’re sorry to hear of the trouble you are experiencing. We kindly suggest having your dealer inspect this concern if you have not done so already, as they will be in the best position to assist. We are also available via private message if you would like any additional assistance during that process.
Laura
FiatCares
 

·
Registered
Joined
·
110 Posts
Mine had this issue, but it was something happening when the turn signal stalk was wiggled, either by bumpy roads or by signaling. As these things do, it eventually went away on its own.
Perhaps coincidentally, (perhaps not) years later, the ECU needed replacing.
 
1 - 5 of 5 Posts
Top