Fiat 500 Forum banner
1 - 7 of 7 Posts

·
Registered
2019 Fiat 500 Lounge Manual
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2019 500 Lounge and look forward to participating in the forum.

I initially succeeded in pairing my iPhone 6s in order to play Google Maps through media as I am a bit deaf.

Suddenly, media Bluetooth would only work as muted. The unmute button would only work with the radio and had no effect in media mode or with the unmute button on the steering wheel.

In order to hear directions through my iPhone, I unpaired the two devices and am now unable to pair them again.

Media produces a Pin but my iPhone no longer recognises Uconnect (with it pairing automatically first time around).

Due to my deafness, any help in resolving the problem will be much appreciated.
 

·
Registered
2019 Fiat 500 Lounge Manual
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks Brian.

I did try that. A pin was generated by the car. However, Uconnect was not recognised by the iPhone and so there was nowhere to enter the pin.

When I paired for the first time my iPhone automatically recognised a a full Uconnect code without any need to enter a pin .. so now neither option is available.

I am looking in my iPhone Bluetooth settings for an opportunity to enter the pin. Is there any other way of entering the pin in order to complete pairing?

Much appreciated,

Denis
 

·
Registered
2019 Fiat 500 Lounge Manual
Joined
·
4 Posts
Discussion Starter · #5 ·
Thanks Brian. I have in fact also tried this. I have also attempted to unpair my iPhone from my laptop and then attempted to re-pair it. Unable to unpair laptop Bluetooth from iPhone and then re-pair it. This is because the function for recognising other Bluetooth devices is stuck in buffering. The laptop Bluetooth recognises the iPhone Bluetooth but is unable to complete the pairing process due the iPhone's buffering. This suggests that the problem is with my iPhone. I will look into a fix for this and report back. Thank you for your kind assistance.
 

·
Registered
2019 Fiat 500 Lounge Manual
Joined
·
4 Posts
Discussion Starter · #6 ·
Thanks for your patience Brian. I have reset my iPhone and have now been able to re-pair it with the car Bluetooth.

Unfortunately, it has not resolved the key issue of media mode being constantly muted and my being unable to find a way of unmuting it.

Whilst the voice settings on Google Maps remain correct .. and initially worked fine with the car Bluetooth .. there is now no sound even with the car Bluetooth unpaired.

I am however able to play Apple Maps through the iPhone once the car Bluetooth has been unpaired.

Do you have any suggestions please regarding unmuting the car Bluetooth media? Thank you for your kind assistance.
 

·
Registered
Joined
·
1,354 Posts
Glad I was able to fumble through this with you! I don't have a modern uConnect in any of my cars (2012 FIAT 500 and a 2011 Jeep Grand Cherokee) so I can't help with that.

You may want to contact MOPAR UK or pay a visit to your local FIAT Studio and they can probably help you out.
 
1 - 7 of 7 Posts
Top