Fiat 500 Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all, I recently had to have my car battery replaced on my 2016 500X and after a couple of days I noticed the keyless entry warning light would turn on for a bit before turning off. Then one day neither of my key fobs worked at all. No locks opening, no lights blinking, no horn beeping...dead. I actually thought there was something wrong with the new battery that I just had replaced. I used the key from the key fob to open my driver side door and the alarm immediately started going off. I could not stop it because the keys were not working so I had to resort to unhooking the battery cable. I tried everything including changing the key fob batteries but every time I hook up the car battery the alarm goes off. The car is out of warranty and the dealer says it might need to have the computers rebooted. At this point I can't even start it to drive it in for service. Anyone else encounter this problem and is rebooting the car computer the answer?
 

· Registered
Joined
·
6 Posts
The car is out of warranty and the dealer says it might need to have the computers rebooted. At this point I can't even start it to drive it in for service. Anyone else encounter this problem and is rebooting the car computer the answer?
 

· Registered
Joined
·
2 Posts
The car is out of warranty and the dealer says it might need to have the computers rebooted. At this point I can't even start it to drive it in for service. Anyone else encounter this problem and is rebooting the car computer the answer?
I have similar issues only I have a message on the dashboard saying "key in ignition"..... My car is a 2016 push start. Can find nothing about this message in the manual or forums. About to take it in tomorrow will update here when diag is found. I suspect faulty software on the computer, I should never get that message.
 

· Registered
Joined
·
2,021 Posts
I have similar issues only I have a message on the dashboard saying "key in ignition"..... My car is a 2016 push start. Can find nothing about this message in the manual or forums. About to take it in tomorrow will update here when diag is found. I suspect faulty software on the computer, I should never get that message.
Hello,
After your dealer appointment, if you still need additional assistance, feel free to send us a private message. We'd be happy to help.

Sarah
Fiat Cares
 

· Registered
Joined
·
2,021 Posts
Thanks for the reply Sarah, am I mistaken in thinking that such a message should not even be programmed into a car with keyless entry?
Hello,
Unfortunately, we were unable to locate the answer to that question either, and your dealer is still in the best position to resolve your concerns. If you have any additional questions after your service, don't hesitate to send us a message.

Sarah
Fiat Cares
 

· Registered
Joined
·
2 Posts
Hi all, I recently had to have my car battery replaced on my 2016 500X and after a couple of days I noticed the keyless entry warning light would turn on for a bit before turning off. Then one day neither of my key fobs worked at all. No locks opening, no lights blinking, no horn beeping...dead. I actually thought there was something wrong with the new battery that I just had replaced. I used the key from the key fob to open my driver side door and the alarm immediately started going off. I could not stop it because the keys were not working so I had to resort to unhooking the battery cable. I tried everything including changing the key fob batteries but every time I hook up the car battery the alarm goes off. The car is out of warranty and the dealer says it might need to have the computers rebooted. At this point I can't even start it to drive it in for service. Anyone else encounter this problem and is rebooting the car computer the answer?
I'm wondering if / how you fixed this issue. Currently our 2016 500X is only giving the "service keyless entry system" light and won't do anything else. We cannot start it thus getting it into the dealer will need to be towed and the closest Fiat mechanic is 130 miles away. Really hoping there is a solution that does not involve towing it in.
Thanks!
 

· Registered
Joined
·
5 Posts
I’m having the exact same issue and my car is currently being towed from wales to Leeds, which has cost me a fortune already. If anyone has any ideas, I’d be grateful! I’ve had the car battery changed, checked the key fob battery, but absolutely nothing other than check keyless entry system. Although it did start once this morning, but then back to nothing again!
 

· Registered
Joined
·
5 Posts
I'm wondering if / how you fixed this issue. Currently our 2016 500X is only giving the "service keyless entry system" light and won't do anything else. We cannot start it thus getting it into the dealer will need to be towed and the closest Fiat mechanic is 130 miles away. Really hoping there is a solution that does not involve towing it in.
Thanks!
Did you resolve this as my car is still out of action and no one can figure out what’s wrong with it? Be good to know what the issue was as I really need to get my car back on the road!
 

· Registered
Joined
·
2 Posts
Discussion Starter · #10 ·
Did you resolve this as my car is still out of action and no one can figure out what’s wrong with it? Be good to know what the issue was as I really need to get my car back on the road!
Hi, sorry for the late reply but to follow up on my initial post the dealer found that water was leaking into the frame in the rear of the car where I guess the electronics for the security system are located. The module was corroded from getting wet. They had to weld the seam in the frame where the hole was, repaint the weld and replace the module. They said it was actually an issue from the factory that they had seen before.

Curiously I am having issues again after 1 1/2 years so perhaps they didn't fix the leak entirely. Very frustrating!
 

· Registered
Joined
·
3 Posts
I'm wondering if / how you fixed this issue. Currently our 2016 500X is only giving the "service keyless entry system" light and won't do anything else. We cannot start it thus getting it into the dealer will need to be towed and the closest Fiat mechanic is 130 miles away. Really hoping there is a solution that does not involve towing it in.
Thanks!
Same issue still doing it after new battery
 

· Registered
Joined
·
2 Posts
I have similar issues only I have a message on the dashboard saying "key in ignition"..... My car is a 2016 push start. Can find nothing about this message in the manual or forums. About to take it in tomorrow will update here when diag is found. I suspect faulty software on the computer, I should never get that message.
Hello CB420, Did they give you a response? My car is having the same issue but it won't start or move?
 
1 - 12 of 12 Posts
Top