Fiat 500 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My 2013 Pop 500 keeps getting the low oil pressure light too. Fiat says they got the P1068 and P106A codes for the cylinder 2 and 3 solenoid valves out of range. They checked the multiair oil activator and said it wasn't clogged. The changed oil, and recommended a new multiair block ?? Had another garage look at it and they changed the multiair screen assembly. No help. 3rd garage says there a re some metal shavings in the newly changed oil and it needs a new engine. Seems like lots of guessing?? ALso, on occasion, when starting in 1st gear, at about 1800 rpm it starts chugging and have to shift up to 2nd. Than again at 1800-2000 rpm it chuggs/sputters ( like out of gas). Any thoughts. Hopefully not guesses but actual experience with these issues. Thanks
 

·
Registered
Joined
·
12 Posts
My 2012 sport 500 had the same P1068 code and eventually Fiat service found metal shavings in newly-changed oil and has recommended replacement. (This occurred at almost the same time as yours, mid September).
Have you learned anything more?
Any other forum members have thoughts / advice?
I am still driving mine with an eye on the oil pressure, while looking for another vehicle and considering whether replacing engine is worth it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
My 2012 sport 500 had the same P1068 code and eventually Fiat service found metal shavings in newly-changed oil and has recommended replacement. (This occurred at almost the same time as yours, mid September).
Have you learned anything more?
Any other forum members have thoughts / advice?
I am still driving mine with an eye on the oil pressure, while looking for another vehicle and considering whether replacing engine is worth it.
I have a new engine being put in :(
 

·
Registered
Joined
·
976 Posts
If the light comes on, it's wise to pull over, shut it off, and have it towed to your mechanic... on any car. Have the pressure checked. The engine runs 10 lbs at idle (per specs) and the light comes on around 4 PSI. As with any car, running w/ inadequate oil pressure can damage an engine.

Off the top of my head, low oil pressure can be a blockage, the oil pressure bypass stuck, a failing pump, or excessive bearing wear... or the sender is defective. As you know, the intake valves on the 500 are opened by oil pressure; makes sense that you could get the other problems IF oil pressure is actually low.

The factory says, after 50K miles, oil use of a quart in 750 miles is OK. I don't know how often you check your dipstick but, if it is using 10% that amount and you use Fiat's extended oil change intervals, it's probably below the add-oil mark. That or it could have been assembled by someone with a hang-over.
 

·
Registered
Joined
·
3 Posts
If you don't mind sharing what was the estimated cost and did you go to the dealer to do this? I am having the same issue - and was told to potentially replace the engine cause the oil pressure isn't where it should be at - like someone else posted here. Greatly appreciate it and good luck!
 
1 - 8 of 8 Posts
Top