Fiat 500 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
How many miles are on your engine? How old is it? Does it only show up after you have a few miles on it, when the oil has warmed up? I hate to say, but it sounds to me like a worn oil pump or maybe worn main bearings... if it has a lot of miles on it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
How many miles are on your engine? How old is it? Does it only show up after you have a few miles on it, when the oil has warmed up? I hate to say, but it sounds to me like a worn oil pump or maybe worn main bearings... if it has a lot of miles on it
How many miles are on your engine? How old is it? Does it only show up after you have a few miles on it, when the oil has warmed up? I hate to say, but it sounds to me like a worn oil pump or maybe worn main bearings... if it has a lot of miles on it.
Oil PRESSURE SWITCH? REPLACED

MULTI AIR VVT? REPLACED

MULTI AIR SOLENOID? REPLACED

OIL CHANGE 5W30 FULL SYN? DONE

HELP!!!!!!!!
How many miles are on your engine? How old is it? Does it only show up after you have a few miles on it, when the oil has warmed up? I hate to say, but it sounds to me like a worn oil pump or maybe worn main bearings... if it has a lot of miles on it.
96k.

2012500c convertible

As soon as max coolant temp is reached it starts chiming

RESOLVE PENDING....... 5w40 motor oil change.....NOT SYN BLEND OR FULL SYN IS RECOMMENDED.....
 

·
Registered
Joined
·
948 Posts
Maybe you have low oil pressure.

Just sayin' .... could be like the person above posted, either the oil pump is worn, or worn bearings can cause low oil pressure.

Especially that it comes on once warmed up and at idle, that points to a real problem not just a bad sensor.
 
1 - 4 of 4 Posts
Top