Fiat 500 Forum banner

21 - 40 of 41 Posts

·
Registered
Joined
·
1,961 Posts
Hello my Fiat 500 e when the radio is turned on does not work, only the Fiat logo and I can not control it or any action appears What is the reason and who has the solution to this problem?
We're sorry to hear that you are also experiencing this infotainment concern. When you do have the opportunity to visit the dealer, please feel free to loop us in! If additional assistance is needed throughout your dealer visit, send us a PM. We'd be happy to connect you with a Case Specialist to assist.

Alison
FiatCares
 

·
Registered
Joined
·
1 Posts
I'm having the same problem but when I go to the website and enter my VIN number it says I'm all up to date.
 

·
Registered
Joined
·
2 Posts
I thought I would post the resolution to my infotainment continuous reboot cycle. Laura from FiatCares on this forum was kind enough to get the ball rolling, collected my information and got me a case number. Then Deidre from US Customer Car FCAgroup.com contacted me and requested the same information, which I gave. I did not hear back so I both emailed and called Deidre. Deidre never got back to me so she dropped the ball.

In the mean time I went to the DriveUconnect website and downloaded the firmware for the radio. It is Uconnect 5.0 MY16 RA2C 11.00.09.00 FF BEV with a release date of 2015-11-16 . Then I started the firmware update process. The screen on my Uconnect radio said that I had the same version already installed (11.0.9.0). With nothing to lose, I decided to install the same version anyway.

The reinstall of the firmware was successful and the continuous reboot cycle problem was fixed. All functions on the infotainment system, including the TomTom navigation, is working again.

Interestingly this problem cropped up around November 3rd. This was the day I had Sirius XM radio activated and it was also the the same date that there is the 1024 week rollover issue with GPS receivers. Maybe one of these things caused the issue? I might never know.
Hi, I also have this problem and when I try to download the firmware it tells me I am up to date, can you send me the DL? thanks!
 

·
Registered
Joined
·
2 Posts
@abenusa thank you for the download link, I have a 500 E with key start. I moved it to on without starting and plugged in USB drive, the fiat logo screen comes up but then it just goes blank and repeats with logo, not reading the usb drive. any suggestions? thanks!
 

·
Registered
Joined
·
1 Posts
I have the same problem with my 2016 Fiat 500e. The screen shows the Fiat and Sirius logos but none of the controls work, except for the volume and mute buttons. The infotainment system is stuck at a station that it was tuned to before I had this problem. It reboots periodically and goes back to this state. I downloaded the update to a USB drive using VIN provided, but when I turn the car on using the ignition key and plug in the drive into the USB slot, nothing changes.
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #37 ·
can you send me the file for the update i have your same problem
Please read through the entire thread. I have posted a VIN and a link to the Uconnect software update website in which you can download the firmware.
 

·
Registered
Joined
·
1 Posts
I thought I would post the resolution to my infotainment continuous reboot cycle. Laura from FiatCares on this forum was kind enough to get the ball rolling, collected my information and got me a case number. Then Deidre from US Customer Car FCAgroup.com contacted me and requested the same information, which I gave. I did not hear back so I both emailed and called Deidre. Deidre never got back to me so she dropped the ball.

In the mean time I went to the DriveUconnect website and downloaded the firmware for the radio. It is Uconnect 5.0 MY16 RA2C 11.00.09.00 FF BEV with a release date of 2015-11-16 . Then I started the firmware update process. The screen on my Uconnect radio said that I had the same version already installed (11.0.9.0). With nothing to lose, I decided to install the same version anyway.

The reinstall of the firmware was successful and the continuous reboot cycle problem was fixed. All functions on the infotainment system, including the TomTom navigation, is working again.

Interestingly this problem cropped up around November 3rd. This was the day I had Sirius XM radio activated and it was also the the same date that there is the 1024 week rollover issue with GPS receivers. Maybe one of these things caused the issue? I might never know.
Would it be possible to send me a link to the firmware? I am having the same issues with no resolve. Thank you
 

·
Registered
Joined
·
1,961 Posts
Would it be possible to send me a link to the firmware? I am having the same issues with no resolve. Thank you
Hi there,

If you're having difficulties updating your software, please send us a private message so we can help guide you through the process.

Thanks,

Courtney
Fiat Cares
 
21 - 40 of 41 Posts
Top