Fiat 500 Forum banner
41 - 42 of 42 Posts

·
Registered
Joined
·
7 Posts
The Uconnect infotainment radio system in my 2016 500e is in a continuous reboot cycle. I timed it and it is almost exactly every 3 minutes that the radio will turn off, screen go completely black for a few seconds, then the Fiat logo come on, and the radio eventually comes on and resumes where it left off. 3 minutes later, it will happen again.

I did activate Sirius XM on Nov 3rd. Shortly after the problem started.

I found an old thread that seems to be related:
2015 radio locking up

Anyone else have this problem? Anyone know of a fix for it? I've already disconnected the 12V negative battery terminal and let the car sit for an hour thinking that might fix it. Nope.
I have a 2012 fiat 500 sport and the radio turns off after a few minutes of it being on. It's really frustrating and it has been happening every since I bought the car brand new from the dealership
 

·
Registered
Joined
·
2 Posts
i have the same problem i need to help I checked the UConnect website it says my
Vehicle up to date it doesn’t need any update wo what can i do ?



The reinstall of the firmware was successful and the continuous reboot cycle problem was fixed. All functions on the infotainment system, including the TomTom navigation, is working again.

Interestingly this problem cropped up around November 3rd. This was the day I had Sirius XM radio activated and it was also the the same date that there is the 1024 week rollover issue with GPS receivers. Maybe one of these things caused the issue? I might never know.
[/QUOTE]
 
41 - 42 of 42 Posts
Top