Fiat 500 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So the other day I got a “Check Stop Lights” warning. Had a look and sure enough the bulb had clearly blown. Replaced the bulb and light unit, no problem.

Shortly after I got a “Check Running Lights” warning. Checked and light on the same side as Stop Light was out. Typical I thought but had the light unit off to replace bulb.

However, when I went to change the bulb it looked fine. I replaced it anyway and refitted the unit. Turn the lights on and it is fine for about five seconds then the warning light comes on. I’ve checked this and the running light definitely comes on (so it is not a blown bulb) for about five seconds but then goes off and the warning light comes on.

I cannot see any obvious loose connection or similar, the bulb seems to be seated OK and vibration when driving or idling doesn’t seem to be having any obvious impact either way.

Any ideas????
 

·
Registered
Joined
·
32 Posts
Just guessing, but the Can Bus systems typically monitor resistance and when they see low resistance, they figure the filament in the bulb has broken. That's why you get the caution light. But they can do the same thing if you substitute a functional bulb with the wrong resistance. Are you certain you replaced the bad bulb with one where BOTH of the filaments have the correct resistance? I'm assuming the bulb in question had two filaments, one for running lights and the other for brake lights, right?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Just guessing, but the Can Bus systems typically monitor resistance and when they see low resistance, they figure the filament in the bulb has broken. That's why you get the caution light. But they can do the same thing if you substitute a functional bulb with the wrong resistance. Are you certain you replaced the bad bulb with one where BOTH of the filaments have the correct resistance? I'm assuming the bulb in question had two filaments, one for running lights and the other for brake lights, right?
It is a single bulb, there’s a separate brake light bulb. But I am beginning to think it could be a bulb related issue.
I am going to try a little experiment later and see if I can determine where the fault might lie.
The replacement bulbs where listed as the correct type, but I am beginning to have my doubts.
I will let you know what I discover!
 

·
Registered
Joined
·
3 Posts
It is a single bulb, there’s a separate brake light bulb. But I am beginning to think it could be a bulb related issue.
I am going to try a little experiment later and see if I can determine where the fault might lie.
The replacement bulbs where listed as the correct type, but I am beginning to have my doubts.
I will let you know what I discover!
Hi, I would be really interested to know if you sorted this, we have a 500L. DRL turns on initially then goes out, so not a blown bulb. On the same side (passenger) the rear break light is doing the same thing. Comes on initially for a few seconds then goes out. I can’t find anything logical on the internet, Halfords are baffled. Bulbs are all fine (but have to say, trying to change the front bulb is an absolute ***** to do).
 

·
Registered
Joined
·
1 Posts
I've got the same problem with the driver's side daytime running light. Took it in today for an oil change and bulb change. Bulb change didn't fix it.
 

·
Registered
Joined
·
3 Posts
@bairdwc i managed to fix it last weekend (it’s been bugging me for over a year) and it was purely by fluke! I happened to notice that one of the rear bulbs was blown - on the same side as the DRL that wasn’t working well (although oddly appeared to work intermittently...?) - changed that bulb and voila - the front doesn’t have an issue anymore. No more yellow triangle warning light - happy days!
 

·
Registered
Joined
·
6 Posts
What year is it? Forgive me if I overlooked the info-I’m new. I have a 2013 and run through bulbs-headlights-brake lights..and now a daytime running light that goes off and on. It’s obviously some kind of issue-electrical, a module..I’m not mechanically inclined-but it’s an issue I’ve seen from others too.
 

·
Registered
Joined
·
3 Posts
It’s. 2014 - honestly double check every light, genuinely I replaced the back light and there has been no issue with the drl since!
 
1 - 8 of 8 Posts
Top