Fiat 500 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I just bought a used 500 sport. It had blue & me on the window sticker, but not navigation. I bought a used tomtom from a 500 owner who no longer wanted the unit. I can't get it pair to the 500 properly. Phone connects fine to the car and to the Tomtom. Anyone know if I'm missing a module or software to make it work? My studio is no help, no knowledge and no interested in help.
 

·
Registered
Joined
·
2,574 Posts
it should work.

I have used my Tom Tom with the suction cup mount with it paired before. so I doubt it's anything specific to Tom Tom equipped cars.

Have you selected Blue and Me on the tom tom and done the user pairing through the steering wheel buttons? I believe you can only do it in park. The car will flash a 4 digit code you must enter into the Tom Tom device. It's at that point they will pair. You'll get different menu selections withing the Tom Tom and the pointer will change to a little Fiat 500.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Yeah, the pairing routine goes fine up to a point. I get the 4 digit code from the car, type it in the tomtom. The tomtom returns a fail message, and the car gets confused. the car says welcome, and shows tomtom in the cluster. However, I have none of the menu selections in the tomtom and the main screen still says "navigate to" and "find blue & me".

I've seen other posts about the car's software version, is there a way for me to check my version? (my studio isn't interested in helping).
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
The only reset I could find was to hold the power button 15 seconds. I tried that, same story. I also did the "restore factory settings" button on tomtom.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Update:

I went to a dealer and they were helpful by running an "options report" where they use the VIN to look up all installed options on my 500. They also ran the report on a 500 with Nav. The options report turned up two possible shortcomings. The car with nav has 2 codes mine didn't. RSZ (TomTom navigation with BLUE ME) and 75F (MOPAR TomTom Navigation Unit). I assume the 75F is the actual interface unit. RSZ appears to be a module on the main computer unit. MOPAR Price is about $800, and I have no idea if I'm missing any wiring harnesses to make it work. I'm not sure this is something I can add after the fact, and at that price it's not worth it. I'll try to keep learning more.
 
1 - 6 of 6 Posts
Top