Fiat 500 Forum banner
1 - 20 of 137 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So, I just purchased a Pop and love it so far. Great little car, but I'm having issues with the Media player via usb stick. I've read all the posts I could find and that helped explain the first issue but not the second.

1. Randomly switches to the Media player when driving with the radio on. I'm assuming that this is the previously reported loose usb stick making and breaking connection and falsely leading the radio into booting the "new" stick that it thinks has been plugged in. My question is if anyone can recommend a specific usb stick brand/model that doesn't do this? Or can I somehow support or pad mine to stop it from vibrating and breaking the connection? It's driving me nuts.

2. The dash Blue&Me display and controls see all the music information (artist, album, genre etc...) from the usb stick but the radio display only sees the artist and song title and won't display folder, album or genre. Because of this I cannot select the music very efficiently from the radio controls. Even when I do use the arrow buttons to scroll by artist it doesn't do it alphabetically like the Blue&Me display and thus is kind of limiting. I guess the radio and the Blue&Me are two different systems running in parallel but with different software and capabilities? I tried my usb stick in two other cars at the dealer and they all behaved the same. Can I fix this? Or, am I doing something wrong with the data on my stick? Or, is this just a quirk in the system?

I like the idea of having my music library on a usb stick permanently in the car but the implementation seems weak at best.

Thanks in advance for your help.
 

·
Registered
Joined
·
470 Posts
My USB would cut off when I went over a bump, drove hard, or turned the head lights on/ flashed the high beams. Now it does not work @ all. I don't think it was was the stick or iPod connector. I think the problem is deeper than the input USB connector in the glove box. I took the car in and the FIAT mechanic had no idea what it was. He said I would have to leave it... I live 40 miles from the dealer and had no one to pick me up. He said there was another car with the same problem. I told him to fix that car... and call me when he had the solution. Never heard from him again. I just pretend that my car never had that option to begin with. Oh funny thing is... There is power... It charges the iPod... but it just does not connect to the system. :' (
 

·
Registered
Joined
·
13,459 Posts
I hooked up my hard drive ipod to the USB. Lock it up big time. Couldn't turn it off. Just said on the screen OK to disconnect. Guess it needs to be a flash drive model. Had to let the ipod battery drain all the way down, before it started to work again. Never use it again on the 500.
Haven't tried my iphone yet!
 

·
Registered
Joined
·
45 Posts
I use a hard drive ipod with mine and while it works great it does want to play the ipod every time I start the car. From another thread I learned to use the Bluetooth to stop the playback - hit the vr button and say "Stop". This stops the ipod from playing and switches me to satellite radio. I am chalking this up to a "quirk" and just deal with it. Other than that quirk the ipod works great and when I want it to play it plays as advertised.
 

·
Registered
Joined
·
249 Posts
1. Randomly switches to the Media player when driving with the radio on. I'm assuming that this is the previously reported loose usb stick making and breaking connection and falsely leading the radio into booting the "new" stick that it thinks has been plugged in. My question is if anyone can recommend a specific usb stick brand/model that doesn't do this? Or can I somehow support or pad mine to stop it from vibrating and breaking the connection? It's driving me nuts.
I've been using a PNY 4gb drive that is about 1 inch long, including the plug and haven't had ay issues with it whatsoever. http://www3.pny.com/category_buymulti.aspx?Category_ID=459

It was $8 (USD) at staples when I bought it.
 

·
Registered
Joined
·
228 Posts
Phone V stick

I had all sorts of problems with mp3 files on a stick,and switched to using my iPhone plugged in and have had no problems. I was getting "invalid file type" messages from the stick,or it would only play 8-10 songs then stop.No such issues with my phone so far.

I do notive the control buttons on the steering wheel get warm,thought it might be the lights (led's) under the keys?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Thanks for the replies. Sounds like I'm not alone here with issues. I think I'll shop for a micro sized USB stick and bug the dealer to bug Fiat about the inconsistencies in the system and hope for a software fix down the road.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Update

I've tried lots of various suggestions but with no changes.

I did buy a micro sized USB stick and that has slowed down the unintended starts from the media port but it still happens. The really weird one was that I drove around for a day with the radio turned completely off and even had it turn on by itself and start playing the media from the stick.

I've also tried various ways of creating and storing MP3's onto the memory stick and the Blue and Me side always sees the album and folders and the radio side never sees it.

Something is definitely amiss. The dealer has been great but in the end no help. At their suggestion I will now got straight to FIAT with my findings. This system has great potential and just needs some tweaks. Hopefully a software/firmware upgrade can fix it.
 

·
Registered
Joined
·
707 Posts
so i have an issue with mine as well. Using an older 2g iPhone. every time I start up my car I set it to SAT radio for live music. Then when I click the back buttons to go to the next station it automatically jumps to the MEDIA [iPhone] source. has this happened for anyone else? this occurs about 9/10 times
 

·
Registered
Joined
·
453 Posts
Yeah, mine does it too. I usually want to listen to it, so it's no big deal, though. I did have a couple times when it seems a shock of some kind (physical, not electrical) kicked it over from radio to USB, or convinced the car that the USB was no longer connected. My USB is a teeny little micro SD reader with a 16gb card that I leave in all the time, so it's not like there's much mass to move around, either.
clearly, software can be easily updated (see EcoDrive). Hopefully they'll figure out the deal and fix it with an upgrade.
 

·
Registered
Joined
·
56 Posts
My in-dash display (The one inside the tach) just says "MP Player" or some sort, but does not display the artist, title, etc.
What setting do I need to change to get that to work?
 

·
Super Moderator
Joined
·
22,120 Posts
My in-dash display (The one inside the tach) just says "MP Player" or some sort, but does not display the artist, title, etc.
What setting do I need to change to get that to work?

Think this is what you need...

To activate (On) or to deactivate (Off) sound system info
displaying proceed as follows:
• Briefly press the MENU ESC button (On) or (Off) will
flash on the display (according to previous setting);
• Press the + or – button for setting;
• Briefly press the MENU ESC button to go back to the
menu screen or press and hold the MENU ESC button
(approximately one seconds) to go back to the main
screen without storing settings.
 

·
Registered
Joined
·
453 Posts
On my 500, the menu item I believe you're referring to is "See Radio".

Tweak, what did you mean by "one of my boot-able media setups"?
 

·
Super Moderator
Joined
·
22,120 Posts
On my 500, the menu item I believe you're referring to is "See Radio".

Tweak, what did you mean by "one of my boot-able media setups"?

Sorry, nothing to do with the car, a boot-able windows 7 installation media on usb rather than on cd/dvd as it allows MUCH faster installation.
 

·
Registered
Joined
·
453 Posts
ah, ok. so you don't use USB for music any more? What do you use for non-radio listening?
 
1 - 20 of 137 Posts
Top