Fiat 500 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello All. New member and 500e owner here. Purchased a used 2015 500e and noticed some strange behavior with the license plate lights.

When the doors are locked or unlocked with the fob the license plate lights come on at what looks like about 10% brightness.

Also happens if you open the doors. When ever everything is locked up the lights go out after about 30 seconds.

The license plate lights are also on (at the same 10%) anytime the car is charging.

It is really dim but it is easy to see at night if you look under the chrome piece at the lights.

They come on full bright when the headlights are on.

Has anyone noticed this? I'm wondering if it is normal or a problem.

I would appreciate any advice.

Thanks.
 

·
Registered
Joined
·
39 Posts
I checked my 2014 500e in the parking lot today. I could nt tell if the license plate lights were on with the door open or if they blinked when I locked or unlocked.

I will check them tonight when it's dark, but in the daylight I would say that mine did not come on at all.
 

·
Registered
Joined
·
39 Posts
I checked in the dark, my lights do not illuminate with the remote lock or unlock feature or with the door open.
Course who knows what Fiat did between 2014 and 2015... but I suspect it is not a feature.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Just an update. The first dealer changed the rear hatch handle and the BCM but it didn't solve the license plate light problem. They said they had to talk to "Fiat engineering". When I didn't hear back I escalated the complaint to Chrysler corporate. They contacted the dealer and the dealer told them the issue had been resolved. Needless to say I expressed my displeasure. After having the car for over 30 days and then lying about the repair really set me off. It took them over 20 minutes to locate the car when we went to pick it up. "Can't find it" seemed to be their answer. I was about to call 911 and report it stolen when they found it.

Chrysler advised us to try a different dealer, so the car is now at a 2nd dealer.

It would also seem that replacement keys are not available. We have tried to order a key from 2 different dealers but nobody can seem to supply one. Chrysler told us the the keys are on "National Backorder"

We are just about ready to trade it in for something else.
 

·
Registered
Joined
·
957 Posts
There may be a short in the loom going to the hatch. The insulation and wire strands break and fray, causing possible shorts and interrupts from repeated tight bending, due to a poorly designed strain relief. It was a common problem on ice 500s.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Well the verdict is in. After 55 days in at the dealer they identified and corrected the problem. According to the tech that worked on the car, at some point the rear handle/license plate light assembly had been changed. The old part number was no longer available so someone put on the updated part number. It is apparently not 100% compatible with the older models.

According to the report, the tech found that whenever the BCM was active there is 1.6 volts going to the license plate lights. The old part number will not light at that low voltage but the new part number will. They swapped a old part number handle from a used vehicle they had in stock and it works OK now. He checked the vehicle that he took the lights from and found the same 1.6v so that appears to be normal.

I guess if we ever have to replace the light/handle assembly at least it's good to know that the glow from the license plate lights is normal. It only took them 55 days, 2 new BCM's and 2 new light assemblies to figure it out.

I hope this info will help anyone that finds themselves with the same issue.
 

·
Registered
Joined
·
1 Posts
Just an update. The first dealer changed the rear hatch handle and the BCM but it didn't solve the license plate light problem. They said they had to talk to "Fiat engineering". When I didn't hear back I escalated the complaint to Chrysler corporate. They contacted the dealer and the dealer told them the issue had been resolved. Needless to say I expressed my displeasure. After having the car for over 30 days and then lying about the repair really set me off. It took them over 20 minutes to locate the car when we went to pick it up. "Can't find it" seemed to be their answer. I was about to call 911 and report it stolen when they found it. Chrysler advised us to try a different dealer, so the car is now at a 2nd dealer. It would also seem that replacement keys are not available. We have tried to order a key from 2 different dealers but nobody can seem to supply one. Chrysler told us the the keys are on "National Backorder" We are just about ready to trade it in for something else.
Hello, I have a 2017 Fiat 500e and I noticed the same today. Not only the license plate light was on very dim, the gauge is also on very dim as well. I noticed it when the car was plugged in. Also I think the rear hatch was not shut properly. I unplugged the charger, make sure all the doors and hatch are close. The light eventually turn off after about 30sec. Hope that helps.
 
1 - 10 of 10 Posts
Top