Fiat 500 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Okay so I am a avid 500 fan, owning a 2012 500 pop which I love to bits, I do not drive too frequently in this car and it has only 39000km on it, yesterday the fist problem arised.
My car when ignited wont shift gears and the clutch feels a little heavier than whats normal, if the car is turned off then both the clutch and the gears shift with ease. The car was services in May this year on about 32000km, my first thought was maybe its the tranmission fluid which might be low? However I called a mechanic who inspected the car but refused to even take a look at the transmission fluid and dismissed this idea rather fast, he did confirmed that the clutch is in working order and that the issue is with the pilot bearing. Once I recieved a qoute from him I phoned antoher service centre to find a compairable price and the shop manager told me that based on what I discribe it cannot be the pilot bearing and its most likely a clutch issue, now I have two conflicting reports.

My problem being, I am not too familiar with technical stuff and might be taken for a ride by these people.
From what I discribed what can cause the gears to act up like it did?
 

·
Registered
Joined
·
513 Posts
It is very likely that your pressure plate failed due to a factory design issue. There is a recall related to that issue. You may not be under warranty but due to it being a safety recall, I would recommend you to contact FiatCAcares (presuming you are in Canada) and explain the situation. It is common for Fiat to replace the failed components. Good luck.
 

·
Banned
Joined
·
4,741 Posts
Someone is going to have to drop the tranny to figure out what is wrong. All of this telepathic diagnosis is BS.

If the pressure plate, throw out bearing, master/slave cylinders failed FIAT should pay for it.

If the clutch disk failed, you will pay for it.

You might want to replace the clutch disc anyway while the tranny is apart. You will pay for that part.

Tedolph
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Okay got the car back from the workshop and it was indeed the clutch plate, Fiat South Africa reckons the recall is for USA vehicles only, so I had to fork out the monies myself, but heck this is a 4 year old car and this was the first time it ever gave me any troubles. I showed the old clutch plate to my brother who is more mechanically minded then me and he reckons that I drove my clutch to hard as it has visible stretch mark. Well this morning I took it for a long drive and it feels as good the day I bought it, so all in all I reckon that I only got myself to blame. Will have to work on my clutch control.
 

·
Registered
Joined
·
16 Posts
Okay so I am a avid 500 fan, owning a 2012 500 pop which I love to bits, I do not drive too frequently in this car and it has only 39000km on it, yesterday the fist problem arised.
My car when ignited wont shift gears and the clutch feels a little heavier than whats normal, if the car is turned off then both the clutch and the gears shift with ease. The car was services in May this year on about 32000km, my first thought was maybe its the tranmission fluid which might be low? However I called a mechanic who inspected the car but refused to even take a look at the transmission fluid and dismissed this idea rather fast, he did confirmed that the clutch is in working order and that the issue is with the pilot bearing. Once I recieved a qoute from him I phoned antoher service centre to find a compairable price and the shop manager told me that based on what I discribe it cannot be the pilot bearing and its most likely a clutch issue, now I have two conflicting reports.

My problem being, I am not too familiar with technical stuff and might be taken for a ride by these people.
From what I discribed what can cause the gears to act up like it did?
 

·
Registered
Joined
·
16 Posts
Same problem with mine First and Reverse buttons . My mechanic replaced transmission oil and the complete part replaced that holds the fluid. $1150 later the car continues not to move regardless of placing it in neutral/ manual/auto/ first or reverse. I’ve seen ppl post on here exact problem yet can seem to get help with a resolution. Appreciate any updates.
 
1 - 8 of 8 Posts
Top